Potential payout delays for Lightspeed Payments Merchants
Incident Report for Lightspeed Restaurant POS (O)
Resolved
This incident has been resolved.
Posted Apr 17, 2024 - 17:56 AEST
Investigating
We're actively investigating payout delays affecting certain Lightspeed Payments merchants based in Australia. We'll provide updates on the matter through our status page here as they become available.
Posted Apr 16, 2024 - 19:03 AEST
This incident affected: Lightspeed Payments.