Kounta Support Centre
Incident Report for Lightspeed Restaurant POS (O)
Resolved
This incident has been resolved.
Posted Feb 14, 2019 - 09:19 AEDT
Identified
Currently, the support.kounta.com support centre is unavailable. Our team are still online and here to help. You can reach us via phone, email and live chat, all of which are located by selecting the '?' anywhere in Kounta.
Posted Feb 14, 2019 - 08:29 AEDT
This incident affected: Support (Phone/Email/Live Chat).