Service Disruption - Support Phone Number
Incident Report for Kounta
Resolved
Thanks for your patience, all our support lines are back up and our team are there to help you with all things Kounta.

As always you can reach us via Email, live chat or phone by selecting '?' from anywhere in Kounta.
Posted about 1 month ago. Nov 14, 2018 - 19:14 AEDT
Investigating
Please note, our team are currently investigating an issue with our support line.

For any Kounta support during this time, you can reach our team using live chat by selecting the '?' anywhere in Kounta or by emailing support@kounta.com.
Posted about 1 month ago. Nov 14, 2018 - 18:50 AEDT