Service Disruption - Back Office Performance
Incident Report for Kounta
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 02, 2019 - 15:33 AEST
Investigating
We have identified an issue causing degraded performance in Kounta Back Office. We will provide more updates shortly.
Posted 3 months ago. Jul 02, 2019 - 15:32 AEST
This incident affected: Back Office.