Support Team - NZ Support Line
Incident Report for Lightspeed Restaurant POS (O)
Resolved
Our NZ line is back online and accepting calls. Thanks for your patience.
Posted Sep 01, 2020 - 13:19 AEST
Investigating
We are currently working to resolve an issue with our telephony provider which has caused our NZ number +64-9-887-8330 to be unavailable. For any assistance during this time, please reach our team via live LiveChat by selecting the Help menu anywhere in the Lightspeed Kounta POS app, or email support@kounta.com
Posted Sep 01, 2020 - 09:19 AEST