Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Sep 25, 2023 - 15:38 AEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 25, 2023 - 15:01 AEST
Scheduled
Another week, another update that'll make your business even more efficient.
When: 15:00 AEST on Monday, September 25. How: You can continue to sell on POS the whole way through. Then after this time, your POS will auto-update.
RESOLVED - Resolved the issue blocking users from updating or adding new credit card details from the Back Office. - Resolved an issue where merchant receipts incorrectly displayed the surcharge amount for split payments with Lightspeed Payments.
IMPROVED - For SmartPay NZ merchants, surcharge values are now clearly shown as 'Payments Surcharge' on receipts and in reporting.
IN CASE YOU MISSED IT Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral! See the 'Refer us' tile on your Back Office dashboard for more details.
Posted Sep 21, 2023 - 13:36 AEST
This scheduled maintenance affected: POS and Back Office.