Kounta Support - Email/Ticket Delays
Incident Report for Kounta
Resolved
This incident has been resolved.
Posted 3 months ago. May 21, 2019 - 09:37 AEST
Investigating
Our team have been made aware of an issue impacting the delivery of support tickets to support@kounta.com, our team are still here and ready to assist via phone or chat. Please select the ? anywhere in Kounta.
Posted 3 months ago. May 21, 2019 - 08:49 AEST
This incident affected: Support (Phone/Email/Live Chat).