Kounta Support - Live Chat
Incident Report for Kounta
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 04, 2019 - 21:54 AEST
Identified
Please note that our live chat tool is currently offline due to technical issues. Our team are still here and happy to help via email or phone using the options shows in the help menu found anywhere in Kounta.
Posted 3 months ago. Jul 04, 2019 - 21:45 AEST
This incident affected: Support (Phone/Email/Live Chat).